Τετάρτη, 29 Μαΐου 2013

Πανελλαδικές-Οι απαντήσεις στην Ανάπτυξη Εφαρμογών και το σχόλιο των καθηγητών



Πανελλαδικές-Οι απαντήσεις στην Ανάπτυξη Εφαρμογών και το σχόλιο των καθηγητών
Πανελλαδικές-Οι απαντήσεις στην Ανάπτυξη Εφαρμογών και το σχόλιο των καθηγητών
Δείτε στο enikos.gr σε συνεργασία με τα φροντιστήρια Διάκριση τα θέματα και τις απαντήσεις στην Ανάπτυξη Εφαρμογών.
Δείτε τα παρακάτω









(Μάθημα: Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον
Ημερομηνία: 29-5-2013)
Θέμα Α
Α1. 1. Λ           2. Σ      3. Σ      4. Λ      5. Σ      6. Λ
Α2.
            k ← 1
            Για i από 1 μέχρι 4
              Για j από 1 μέχρι 5
                Αν ΠΙΝ[i,j] <> 0 τότε
                  Α[k] ← i
                  A[k+1] ← j
                  A[k+2] ← ΠΙΝ[i,j]
                  k ← k+3
                Τέλος_αν
              Τέλος_επανάληψης
            Τέλος_επανάληψης
Α3. α.  πολυπλοκότητα των υπολογισμών, επαναληπτικότητα των διαδικασιών, ταχύτητα εκτέλεσης των πράξεων, μεγάλο πλήθος δεδομένων. (σελ. 19)
β. ο πίνακας είναι μη ταξινομημένος/ ο πίνακας είναι μικρού μεγέθους/ η αναζήτηση σε ένα συγκεκριμένο πίνακα γίνεται σπάνια. (σελ. 65)
γ. ο φυσικότερος/ πιο ανθρώπινος τρόπος έκφρασης των προβλημάτων, η ανεξαρτησία από την αρχιτεκτονική του υπολογιστή και άρα η δυνατότητα μεταφερσιμότητας των προγραμμάτων, η ευκολία της εκμάθησης και εκπαίδευσης, η ευκολότερη διόρθωση λαθών και συντήρηση των προγραμμάτων. (σελ. 127)
Α4. α.
            Για i από 1 μέχρι 99
              Για j από i+1 μέχρι 100
                  Διάβασε Π[i,j]
              Τέλος_επανάληψης
            Τέλος_επανάληψης
β.
            Διάβασε Α, Β
            Αν Α<Β τότε
              Α ← Β
            Τέλος_αν
            Εμφάνισε Α
Α5. 1.ε             2.ζ        3.στ     4.α       5.β       6.γ       7.δ
Θέμα Β
Β1.
Β2.
            Για i από 1 μέχρι 100
              Αν Π[i] = ΨΕΥΔΗΣ τότε
                πλψ ← πλψ +1
                 Π[i] ← ΑΛΗΘΗΣ
              Tέλος_αν
            Τέλος_επανάληψης
            Για i από 100 μέχρι (100-πλ+1) με_βήμα -1
              Π[i] ← ΨΕΥΔΗΣ
            Τέλος_επανάληψης
Θέμα Γ
Αλγόριθμος SAR
Για i από 1 μέχρι 30
  Διάβασε ΚΩΔ[i]
  Για j από 1 μέχρι 10
    Διάβασε ΚΕΦ[i,j], ΑΚΡ[i,j]
  Τέλος_επανάληψης
Τέλος_επανάληψης
Για i από 1 μέχρι 30
  s1 ← 0
  s2 ← 0
  Για j από 1 μέχρι 10
    s1 ← s1 + ΚΕΦ[i,j]
    s2 ← s2 + ΑΚΡ[i,j]
  Τέλος_επανάληψης
  ΜΟ[i,1] ← s1/10
  MO[i,2] ← s2/10
Τέλος_επανάληψης
Για i από 1 μέχρι 30
  Αν ΜΟ[i,1] <= 1,8 τότε
    περκ ← 1
  Αλλιώς_αν ΜΟ[i,1] <= 2 τότε
     περκ ← 2
  Αλλιώς
     περκ ← 3
  Τέλος_αν
  Αν ΜΟ[i,2] <= 3,6 τότε
    περα ← 1
  Αλλιώς_αν MO[i,2] <= 4 τότε
    περα ← 2
  Αλλιώς
    περα ← 3
  Τέλος_αν
  max ← περκ
  Αν περα > max τότε
    max ← περα
  Τέλος_αν
  Εμφάνισε ΚΩΔ[i]
  Αν max = 1 τότε
    Εμφάνισε «Χαμηλός SAR»
  Aλλιώς_αν max = 2 τότε
    Εμφάνισε «Κοντά στα όρια»
  Αλλιώς
    Εμφάνισε «Εκτός ορίων»
  Τέλος_αν
Τέλος_επανάληψης
Για i από 2 μέχρι 30 
Για j από 30 μέχρι i με_βήμα -1
    Αν ΜΟ[j-1, 1] < MO[j,1] τότε
     Αντιμετάθεσε ΜΟ[j-1,1], MO[j,1]
     Αντιμετάθεσε ΚΩΔ[j-1], ΚΩΔ[j]
      Αντιμετάθεσε ΜΟ[j-1,2], MO[j,2]
    Tέλος_αν
  Τέλος_επανάληψης
Τέλος_επανάληψης
Για i από 1 μέχρι 3
  Εμφάνισε ΜΟ[i,k], ΚΩΔ[i]
Τέλος_επανάληψης
Για i από 2 μέχρι 30   
  Για j από 30 μέχρι i με_βήμα -1
    Αν ΜΟ[j-1, 2] < MO[j,2] τότε
      Αντιμετάθεσε ΜΟ[j-1,2], MO[j,2]
    Αντιμετάθεσε ΚΩΔ[j-1], ΚΩΔ[j]
      Αντιμετάθεσε ΜΟ[j-1,1], MO[j,1]
    Tέλος_αν
  Τέλος_επανάληψης
Τέλος_επανάληψης
Για i από 1 μέχρι 3
  Εμφάνισε ΜΟ[i,k], ΚΩΔ[i]
Τέλος_επανάληψης
Τέλος SAR
Θέμα Δ
ΠΡΟΓΡΑΜΜΑ COMENIUS
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: EL[5], ES[5], αρ, θ, i
  ΧΑΡΑΚΤΗΡΕΣ: χωρ, απ
  ΠΡΑΓΜΑΤΙΚΕΣ: ποσ
ΑΡΧΗ
ΓΙΑ ΑΠΟ ΜΕΧΡΙ 5
  EL[i] ← 0
  ES[i] ← 0
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
  ΔΙΑΒΑΣΕ χωρ, απ
  ΑΝ χωρ = «EL» τότε
    EL[αρ] ← EL[αρ] + 1
  ΑΛΛΙΩΣ
    ES[αρ] ← ES[αρ] + 1
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ «Για Διακοπή της εισαγωγής πατήστε Δ ή δ»
  ΔΙΑΒΑΣΕ απ
ΜΕΧΡΙΣ_ΟΤΟΥ απ = «Δ» Ή απ = «δ»
ΚΑΛΕΣΕ ΜΕΓ_ΠΟΣ(EL, ποσ, θ)
ΓΡΑΨΕ «Ελλάδα:», θ, ποσ
ΚΑΛΕΣΕ ΜΕΓ_ΠΟΣ(ES, ποσ, θ)
ΓΡΑΨΕ «Ισπανία:», θ, ποσ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
====================================
ΔΙΑΔΙΚΑΣΙΑ ΜΕΓ_ΠΟΣ(Π, π, θ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Π[5], θ, imaxs
  ΠΡΑΓΜΑΤΙΚΕΣ: π
ΑΡΧΗ
max ← Π[1]
θ ← 1
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 5
  ΑΝ Π[i] > max ΤΟΤΕ
    max ← Π[i]
    θ ← i
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
s ← 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
  s ← s + Π[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ποσ ← max/s
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
Επιμέλεια απαντήσεων:
Γιώργος Χασάπης
Σχόλια: Τα θέματα φέτος, χωρίς να χαρακτηρίζονται μεγάλης δυσκολίας, ήταν σίγουρα πιο απαιτητικά από τις τελευταίες χρονιές. Σημεία όπως το Α4 και το Β2 απαιτούσαν κριτική σκέψη και καλή κατανόηση της διδακτέας ύλης και δεν ευνοούσαν την «παπαγαλία». Το Γ4 μπορεί να θεωρηθεί δύσκολο ερώτημα για τα μέχρι τώρα δεδομένα των πανελληνίων.
Δημοσίευση σχολίου